forest.net bar

Home --> Articles --> Mac OS Go Fish

tiny logo
new bullet Updated
01/13/12

Contribute
contribute button
Today!

Consulting Info

Education

Macintosh

Macworld

Marcus Music

Nature

Pets
  Dobbyn
  Sally & Pet
   Rescue

Single Parents
  Resources

Soccer Photos

Friends & Family

ilene n dobbyn icon

Mac Corner: Your Mac OS - "Go Fish," Part 1

By Ilene Hoffman Reprinted from TechRepublic.com
November 4, 1999

In our first article on Macintosh system installs, "Mac Corner: Preparing your hard drive for Mac OS 9," we explained how to install a new system without messing up your hard drive; however, we didn't discuss what system you should run. There are now three major OS versions (with version updates) that users can choose to run on their machines: Mac OS 7.x, Mac OS 8.x, and Mac OS 9.x. The .x is a generic nomenclature to refer to all the various updates of that particular operating system.

Most people don't really choose their operating system; they just run what came on their computer when it was purchased. Generally, that's a good idea. You should never try to install a system older than the one that was installed on your hardware. New systems offer enhancements that some of us need, but they can plague us with more problems. These problems don't usually exist with the OS itself but with third-party commercial applications, hardware drivers, and shareware we install. The more adventurous among us (and those looking for specific system enhancements) often upgrade to the newer systems as they come out. The rest of us let "someone else" test the bleeding edge of technology before we upgrade. The general rule of thumb is, "If it isn't broke, don't fix it;" but if you yearn for the latest and greatest applications, then by all means upgrade!

In the next four articles, we'll examine these different operating systems and some of their peculiarities and enhancements. This history will aid you in choosing the system for your needs and provide an overview of system complexities.


The Oldest OS You Really Want

Surprisingly, many people are still running old versions of System 7, which were originally introduced way back in 1991. There are many flavors of System 7: OS 7, OS 7.1, OS 7.5, OS 7.5.3 (plus revision 2) and OS 7.5.5 Update. For the best performance, you shouldn't be running any system older than Mac OS 7.5.5.

Mac OS 7.5.5 is also the last Apple system software update that's supported on the following legacy machines: Mac Plus, SE, Classic, Portable, PowerBook 100, SE/30, LC, Mac II, Mac IIx, and the Mac IIcx. (None of these machines has 32-bit memory addressing, which is necessary on newer operating systems.) Even if Connectix's MODE32 is installed, newer systems won't run on these old machines. (You can, however, find Web pages that show you how to force various hardware to run operating systems that aren't supported by Apple.)

7.5.5 Update Enhancements

Introduced in September 1996, 7.5.5 Update provides enhancements for many machines. Virtual memory was revised, it allows faster launching for PowerPC-native applications, and it has the ability to create a Universal System Folder to boot a variety of machines. It also eliminates a great deal of system freezes and increases reliability when sharing a printer over a network. A much-requested enhancement was also added: The comments in the "Get Info" window are no longer deleted when the desktop is rebuilt. The Finder is improved so that copying is done asynchronously, which means other applications can still function. In addition, several crashing bugs were fixed.

Machine-specific enhancements include:
  • Improved floppy disk formatting for 604 and 604e microprocessor-based systems
  • Reduction of Type 11 errors on PowerPC-based machines
  • Better sound use in applications on the Quadra and Centris systems, which have been upgraded with the Apple Power Macintosh Upgrade Card
  • More reliable Ethernet controllers in the 5400 and 6400 series
  • In addition, the Monitors & Sound control panel replaced the Sound & Displays control panel in PowerPC-based computers with PCI slots.

A small application called Network Software Selector (NSS) allows users of 68030-, 68040-, and early PowerPC-based computers to choose between Open Transport and classic AppleTalk if both are installed. Many other pieces of the OS were upgraded between 7.5.3 and 7.5.5. You can find complete information in three Apple documents titled "System 7.5 Update 2.0: What's New in This Update."

Tech Info Document #19134
Tech Info Document #19135
Tech Info Document #19136

Also see the System Update 7.5 Update 2.0 FAQ, which is covered in six documents:

Tech Info Document #19458
Tech Info Document #19459
Tech Info Document #19460
Tech Info Document #19461
Tech Info Document #19462
Tech Info Document #19463


Install requirements In order to install this update, you must be running Mac OS 7.5.3. You need at least 4 MB of RAM in your Mac, but 8 MB is required to install PowerTalk and QuickDraw GX. For a Power Macintosh computer, you need 8 MB of RAM (16 MB is required to install PowerTalk and QuickDraw GX). To install Open Transport, you must have a Macintosh or PowerBook with at least 5 MB of RAM or a Power Macintosh computer with at least 8 MB of RAM.

If your computer has System 7.5, 7.5.1, or 7.5.2 installed, you should use System 7.5 Update 2.0 to upgrade to System 7.5.3. You can use this update on all Macintosh and Mac OS-compatible computers up to, but not including, the new generation of iMacs and G3s and G4s. If you need System 7.5.3, you can download the full install from Apple's software site. It's broken into 19 pieces, averaging 1,200 KB each. You can access System 7.5.5 Update from that page also, or you can download it from either Apple's ftp site or Web page.

You can choose to download the full net install or three separate self-extracting disk image files. Disk Copy can be used to mount these files. Remember to install the correct language version for the operating system you wish to run.

OS 7.5.5 Known Issues

  • If you have Energy Saver version 1.2 or earlier installed in your control panel, you should remove it before installing System 7.5.5 Update. (Energy Saver control panel version 2.0 or higher is okay.)
  • QuickTime 2.5 runs with this update but must be installed separately. Generally, it's best to run the latest version of QuickTime, which is QuickTime 4.x.
  • This update is not approved for installation on Apple Workgroup Servers.
  • You should only use the update made for your particular language system. Do not install the U.S. update on any foreign language operating system.
  • You cannot install the System 7.5.5 Update on a PowerBook 1400.

In this article, we've examined Mac OS 7.5.5. Our next article will review System 7.6, including the 7.6.1 update. Come back tomorrow to read the details!

Helpful Documentation

If you're intent on running older software, Apple provides a System Software Version Matrix covering OS 6.0.x through OS 7.0.1 in the Technical Information Library - Tech Info Document #18046.

Apple has other helpful OS charts, too. For a list of Macintosh models that can run different versions of System 7.1 through 7.6.1, as well as a list of necessary system enablers, see Tech Info Document #21176 and Tech Info Document #8970.

Ilene Hoffman, MS, is a Macintosh/Internet writer, trainer, and consultant based in the Boston area. She is Senior Editor at MacFixIt.com, Contributing Editor at MacTech Magazine, and the perpetrator of the Hess Macworld Expo Events List. She also hosts weekly Mac conferences on Talk City and AOL.

Tech Republic Editorial Disclaimer

The authors and editors have taken care in preparation of the content contained herein but make no expressed or implied warranty of any kind and assume no responsibility for errors or omissions. No liability is assumed for any damages. Always have a verified backup before making any changes.
Contact Info.

ileneh-atthisplace-comcast-dotthe-net
Webmaster
Press Inquiries
TOC Updated: 01/13/12
Other Info.


Site History